rs232 et arduino

Portrait de philb

Quelqu'un peut il me dire comment Arduino envoie une chaîne de caractères sur serial.print.

j essaye de récupérer cette chaîne dans Windev mais au delà d un caractère envoyé il découpe la chaîne en plusieurs morceaux . par exemple pour bonjour   il peut envoyer b puis onjour  ou bon+jour......

est il possible de corriger ce problème.

par avance merci

Portrait de brossden

Bonjour

Je ne pense pas que le problème vient de l'Arduino mais plus du programme sous Windev, le problème doit venir que tu ne laisse pas le temps à ton module Arduino de transmettre l'intégralité du message !

Tu peux tester ceci qui fonctionne !

Programme Windev :

// Il te faut adapter le numero du port com à ton cas !

MaChaine est une chaîne
Lignecom est un booléen
Lignecom = sOuvre(5, 2000, 2000)
SI Lignecom = Vrai ALORS
    sFixeParamètre(5, 9600, 1, 7, 0)
    TANTQUE Vrai
        TANTQUE sDansFileEntrée(5) = 0
            Trace(sDansFileEntrée(5))
            Multitâche(-10)
        FIN
        Multitâche(-10)
        MaChaine = (sLit(5,2000))
        Trace (MaChaine)
    FIN
SINON
    Erreur("Erreur d'ouverture de COM5")
FIN

Puis le programme Arduino

int N;
void setup() {
  // put your setup code here, to run once:
  Serial.begin(9600);
  delay(10);
  Serial.print("Bonjour comment allez vous ce matin ?");
  delay(10);
  pinMode(7, OUTPUT);
}
void loop() {
  // put your main code here, to run repeatedly:
  N = N + 10;
  digitalWrite(7, HIGH);
  delay (1000);
  Serial.println("Bonjour comment allez vous ce matin ?");
  Serial.print("Valeur de N = ");
  Serial.println(N);
  digitalWrite(7, LOW);
}

Voilà j'espère que tu trouveras ici la solution à ton problème

Pour ceux qui n'ont pas Windev : Lecture Port COM

Bonne journée à tous

Portrait de philb

merci beaucoup pour les tuyaux.

moi je passais par sEvénement(4,sEveCaractèreReçu,"evenement") 

8 bits et non 7

SI sOuvre(4,1000,1000,sTimeoutDéfaut,Vrai) ALORS
        sFixeParamètre(4, 9600,0,8,0,Faux,Faux,Faux)
    sEvénement(4, sEveCaractèreReçu, "LectureCaractère")
    FIN

Portrait de brossden

Pas de quoi si cela t'a rendu service !