probleme d'initialisation avec esp8266 01

Portrait de magmasanne

bonjour;

voila 4 dimanches que je passe à essayer de connecter mon esp8266 mais je n'y arrive pas, je suis tout a fait débutant dans ce domaine, et j'apprends l'electronique pendant mon temps libre avec l'electronique pour les nuls.

j'ai visionné encore et encore la video d'U=RI (qui est la loi d'ohm et qu'il faut connaitre par coeur, voyez ,j'apprends mes leçons), concernant l'esp 8266., j'en ai visionné bcq d'autre mais en anglais

je n'ai pas de probleme avec les commandes AT via le port serie et mon esp est connecté, je le vois affiché sous ma connection wifi, c'est pour la suite du programme, j'aimerai savoir comment il faut proceder exactement, à partir de # include <SoftwareSerial>, j'ai copié collé le programme sans oublier mon ssid et mdp, ensuite je televerse mais arduino me dit que l'initialisation n'est pas reconnu ou je ne sais pas trop quoi, j'ai écrit le programme à la main, pareil, les broches sont bien sur 10/11. 

je veux vraiment réussir, pour l'instant je veux juste commander un relais une voie via mon smatphone, j'ai déja une caméra avec l'app YYP2P mais elle c'est initialisé toute seule, je peux ajouter le relais dessus en ajoutant un composant?

ensuite, j'ai telechargé smartconfig, il m'affiche ma Bbox en ssid mais mon mot de passe n'a aucun effet, mais est ce ma box ou l'esp qu'il doit reconnaitre d'abord?

je remercie d'avance celui ou celle qui m'aidera, j'y parviendrai, c'est sur mais là je suis dépité.

Merci

Portrait de brossden

Dans le tutoriel tu trouveras Ceci ! qu'il faut suivre étape par étape !

Voilà les montages possibles pour réaliser la programmation !

Si tu n'y arrives pas avec cela ton cas est désespéré ! :o)   (sourire)