Fonctionne si liaison RST+EN

Portrait de jeromedc

Bonjour,

Par hasard, j'ai pu faire fonctionner mon NodeMCU LUA Amica V2 en reliant les pins RST et EN.

Sinon, j'obtiens :

warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

quand j'essaie de téléverser.

Qu'en pensez-vous ?

Puis-je continuer à l'utiliser comme ça (en gardant ces 2 pins reliés tout le temps) ?

Merci d'avance pour vos réponses.

Portrait de jeromedc

Bonjour,

Merci pour ta réponse, mais cela ne fonctionne pas, il ne se passe rien quand j'appuie sur ces boutons.

De plus, pour information, aucune lumière ne s'allume quand je branche la carte.

Par contre, dès que je relie RST et EN je peux téléverser (je n'ai essayé que l'exemple de blink) et la LED incluse clignote correctement.

Dès que j'enlève la liaison entre ces 2 pins tout s'arrête.

Pour info, j'ai une autre carte identique qui fonctionne très bien sans devoir faire cette liaison.

Portrait de jeromedc

Oui, mais je voulais savoir si cela pouvait causer des problèmes de relier ces 2 pins ou si il y avait un moyen de fixer la carte...

De plus, je n'ai pas trouvé à quoi servait le pin EN (le RST c'est pour le reset a priori).

Portrait de Walter

Comme le dit Brossden c'est le Enabled, de ce que j'ai compris, celui-ci doit être a VCC.
 

A priori c'est ce que tu fait en le reliant au RESET.
Tu pourrais le vérifier en prenant la tension a EN sur des deux cartes et comparer?

Portrait de jeromedc

Effectivement, sur la carte qui marche j'ai bien de la tension sur EN alors que sur l'autre non.

Du coup, il vaudrait peut-être mieux que je relie EN à un pin en 3.3V plutôt que sur RST, non ?

Pensez-vous qu'à terme ce soit gênant de faire comme ça ?

Portrait de Walter

Personnellement je ne peux pas t'en dire plus, perso moi je relie EN et RST pour pouvoir être réveiller après un "deepsleep", par contre cela m'empêche de reprogrammer l'ESP