Contact sec (vraiment sec :-) ) - RESOLU !!

Portrait de lolo78

Bonjour,
J'ai un souci avec un contact sec sur un clavier filaire situé à l'entrée de ma maison.
Sur ce clavier (marque EXTEL SAFE) il y a un bouton de sonnette.

2020-09-01_19.46.02.jpg

Les fils de ce bouton, lorsque le clavier est livré, ne sortent pas de la gaine et rien n'est expliqué concernant le raccordement de ce bouton sur la notice. Mieux, le SAV de la marque me dit que le bouton sur le clavier ne sert à rien et que je n'en ai pas besoin...
Donc recherche et ouverture du clavier. Je trouve les 2 fils qui correspondent au bouton et vais les rechercher dans la gaine pour les utiliser (dans mon cas un rose et un vert).2020-09-03_13.16.50.jpg

2020-09-03_13.25.29.jpg
Après test à l'ohm mètre, il y a bien contact lors de l'appui sur le bouton, un contact qui persiste tant que l'on appui sur le bouton.

J'ai de l'autre côté une sonnette avec 4 fils. 2 pour l'alimentation en 12V et 2 autres, qui quand ils sont en contact, déclenchent la sonnerie. Je l'ai testé en direct, tout fonctionne parfaitement.

Je me dis parfait! mon bouton poussoir fait contact quand on appui et j'ai besoin de ce contact pour faire sonner ma sonnette sauf que rien ne se passe.

Y a-t-il quelque chose de spécifique sur un contact sec de ce type ? Faut-il une valeur ohmique pour effectuer un déclenchement ? Je n'y comprends plus rien.

D'avance merci pour votre aide ;-)

Portrait de Zebra

Avec ton multimètre quelle résistance, obtiens-tu lorsque le bouton est appuyé ?

De plus les fils vert et rouge sont-il vraiment libres de tout potentiel ?

Portrait de hercule124

Bonjour,

La notice est disponible sur ce lien :

http://sav.cfi-extel.com/a/upload/pdf/109119_notice.pdf

Le contact sec du bouton de sonnette se branchera sur les fils violet et jaune

Le service technique Maisonic.com

Portrait de lolo78

Bonjour Zebra,

J'ai entre 17.5 et 20 ohm entre les fils du bouton.

Par contre, je me suis apperçu et j'ai dis une erreur que j'avais entre les 2 fils de la sonnette 4.7V alors que je pensais qu'ils étaient à 0V (donc sur la sonnette 2 fils pour son alimentation en 12V et 2 fils pour faire contact à 4.7V). C'est donc ce petit voltage que la sonnette ne peut pas prendre en compte.


Pour maisonic :

J'ai déjà contacté le SAV de chez vous qui m'a demandé pourquoi j'avais besoin d'une sonnette .. !!!! Si j'achète ce modèle c'est parce que j'ai besoin d'un bouton de sonnette pour qu'on puisse m'avertir que quelqu'un est à la porte. Quant à votre réponse du violet et jaune, elle concerne l'ouverture d''une porte via une gâche électrique d'après votre notice. Croyez-vous que je vais connecter le bouton de la sonnette pour que la personne ouvre une porte ????? 

vj.jpg

Portrait de hercule124

bonjour,

je comprends pas , le bouton avec une cloche c'est bien un bouton d'appel !

vous pouvez rajouter un carillon chez vous afin d'etre prévenu.

ou alors vous avez acheter juste un digicod ?

Portrait de lolo78

Voilà mon schéma

cablage.jpeg

Où je connecte le carillon pour vous et sur quels fils ? vous me dite le jaune et le violet et quand je test le bouton c'est le rose et le vert qui n'apparaissent nul part dans votre notice.

Sur mon schéma, la liaison en rouge ne permet pas de déclencher la sonnette. Pourquoi ?

Je vais vous donner la réponse : je pense que les 4,5V envoyés dans le bouton de la sonnette ne lui plait pas et qu'il faut passer par un relais que je pense avoir trouver car il faut relayer un contact sec libre de potentiel vers une action d'enclenchement du 4,7V.

2 hypothèses:

1/ passer par une carte Arduino pour faire déclencher le contact

2/ passer par un relais de type détection de fuite ou capteur de pluie - Solution que je vais essayer car la plus simple pour moi à ce jour. J'ai donc acheter ça :

capteur2.jpg

Portrait de Zebra

Erreur de ma part je n'avais pas tout lu !

Portrait de lolo78

Non, ta réponse m'a permis de voir que j'avais une tension pour la sonnerie de l'autre côté :-)

Portrait de hercule124

oui , je trouve ca bien compliquer et je vois pas l'interet d'un relais .

logiquement le bouton est en commun avec la masse , lorsqu 'il est fermé il commute votre carillon. 

après on peut bricoler mais ca me parait bizarre que le fabriquant n'a rien prévu  pour le  bouton d'appel sur le digicode.

Portrait de lolo78

En fait, comme les fils du bouton sont reliés à la carte électronique du clavier et que tout passe par cette dernière, j'ai l'impression qu'elle ne veut pas des 4,7V qui y passe. La puissance de la sonnette doit être d'environ 3 /4W ce qui ferait environ 850mA dans le circuit. Le boitier consomme lui 100mA. C'est peut-être trop pour lui ? je ne sais pas.

En tout cas, le relais me permettrait de dissocier les 2 "réseaux".

Moi aussi je trouve ça bizarre que le bouton ne soit pas prévu d'autant que les fils sont par défaut quand on reçoit le digicode cachés dans la gaine (non apparent avec 4 autres fils et non listés dans la notice) et que quand on regarde d'autres notices pour des claviers identiques en terme de fonctionnement ils y sont !!

detail.jpg

Portrait de Zebra

Tu as le type de ta sonnette STP !

Il faut surement relier la masse de la sonnette soit relié à la masse de ton digicode pour que cela fonctionne.

Un des deux fils de la commande de la sonnette doit être une masse ! ( 0 Volt )

Portrait de lolo78

Bonjour Zebra,

C'est une sonnette à 5€ de chez Aliexpress ;-)

Pas de marque mais je peux faire une photo du circuit intérieur.

Pour mon relais de pluie/ humidité, je l'ai reçu hier mais pas de bol, en testant avant de le brancher sur le clavier, je me suis aperçu qu'aux bornes de l'entrée de la sonde j'avais déjà 5.4V donc je pense que ça ne marchera pas non plus et je ne l'ai pas essayé.

Ce matin, j'ai re-vérifié mes fils arrivant de mon clavier à l'extérieur. J'ai une tension arrivant de mon bouton de 0.016V à 0.02V au repos qui passe à -0V quand on appui sur le bouton. On peut quelque chose avec une tension si faible en NO ?

Portrait de lolo78

La sonnette

2020-10-15_08.34.42.jpg

2020-10-15_08.35.23.jpg

2020-10-15_08.35.07.jpg

2020-10-15_08.35.07-2.jpg

2020-10-15_08.36.37.jpg

Portrait de hercule124

Bonjour,

pour trouver le fil qui correspond au bouton ( cloche si il existe c'est a se posé la question) ,essaye ceci alimente le boitier prend ton ohmetre le moins sur gnd du boitier avec l'autre fil du ohmetre test tout les fils un part un en appuyant a chaque fois sur le bouton cloche (sauf le fil rouge +12v) et si tu obtiens une continuité proche du zéro tu auras ton fil .

si tu ne trouves pas essaye la même chose avec le com.

Portrait de lolo78

C'est ce que j'ai fait dès le début et c'est comme cela que j'ai trouvé le rose et vert pale (l'ohmètre sonne et j'ai 25 ohms).

Tu veux quand même voir si il y aurait une masse avec le boitier, c'est cela ?

Portrait de hercule124

tu as fait aussi le test avec le point com en testant chaque fil .

si tu branches le sw  du carillon sur le gnd ou com et l'autre sw sur le fil rose ou vert pal ca donne quoi ?

25 ohms c'est beaucoup pour un bon contact

Portrait de lolo78

Ok, dès que j'ai du temps (ce WE), je re-démonte le clavier et je fais le test des fils avec la masse du boitier et le com.

Pour le carillon, je vais faire le test tout à l'heure ;-)

Portrait de hercule124

l'idée est de trouver un point de contact proche du zero ohm.

attention fait bien les tests ,si tu envois un courant trop important dans le carillon a 5 euro tu risques de l'endommager.

je serais absent pendant plusieurs jours  , bon courage.

Portrait de lolo78

Bon, j'ai quand même été tester mon petit relais.. J'ai regardé la résistance malgré ses 5.4V, j'avais 0 ohm en contact.

D'abord à vide, ça fonctionnait parfaitement et après sur le clavier.

Et bien..... ça fonctionne !!!!

Pour résumer, le clavier accepte la tension mais pas la puissance (même faible) de la sonnette. Il faut donc séparer les 2 circuits.

Merci à ceux qui ont pû me faire avancer sur le Schmilblick, quant aux autres...

2020-10-15_18.31.57-1920.jpg